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Merging

<<<
Donato da Montorfano, Crocifissione, c. 1497, fresco, 730 x 880 cm (detail).
3D scanned in 2014 in Santa Maria delle Grazie, Milan.
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Merging

Merging re-scans

Example

The Merging Application works with RIS files and is used to merge a re-scanned
section with its corresponding base tile. It is recommended that all re-scans are
merged with their tiles before moving on to the next processing step: Editing.

The following example demonstrates the merging of tile 01B with tile 01B_RS1
(RS = rescan). 01B is the main tile and 01B_RS1 is the rescanned section,
sharing the same origin.

Reasons for having re-scans of one or more sections in a tile include:
a) Local vibrations: these appear as regular patterns of vertical lines
in specific areas. In such a case, it would not have been necessary to
modify the settings of the scanner before rescanning the necessary area.
b) Areas with black data: these result from too low a laser intensity. In
this case the settings (laser intensity, exposure or threshold) would have
been changed prior to rescanning.
c) Areas that are out of range: these occur when the laser is either too
close or too far from the object. In this case it would have been necessary
to use the hand wheel to modify the distance (z-axis) between the scanner
and the object. The use of a caliper or a ruler to know the exact distance
moved is essential, as we will see in the merging tutorial.
For the Merging Application to work properly it is important that the rescans
were done with the same origin as the base tile. This will ensure that the rescan
is in the correct position in relation to the original tile. It is recommended that all
rescans comprise some extra area to allow for a margin of error when merging.
For more information about re-scans see Lucida Operator’s manual, p.p. 31-33.

01B
This object has a complex
topography. The area in black was
out of range (in this case, too far away
from the scanner). The resulting data
from the first scan is the file 01B.

01B_RS1
Keeping the same origin, a second
scan was done (re-scan) after
modifying the distance to the object.
The re-scanned tile has the name
01B_RS1.
(The new black areas are caused
by the scanner being too close to
the object).
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01. Open the Merging Application and load the main tile (01B.ris).
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03. The following message will appear: 'Please enter the “z” axis caliper reading
in millimetres' (the displacement value). If the distance of the scanner to the
object was not modified, enter 0. If the scanner was moved, enter the distance
in millimetres, which you should know from the scanning session. Movement
away from the object is recognised by the software as a positive value and
movement closer to the object as a negative value.

02. Load the first re-scan (01B_RS1.ris).
In this case the scanner was moved 10 mm away from the object thus the value
entered is 10. If the scanner was moved 10 mm closer to the object, -10 would
be entered.
The result of the merge will appear along with the window shown in step 5.
The following images illustrate an example of a succesful merge using the
correct displacement value and an unsuccesful merge using an incorrect
displacement value.
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01B and 01B_RS1
succesfully merged with the correct
displacement value.

01B and 01B_RS1 were not
succesfully merged in this case
because of an incorrect displacement
value. Note the thick black line that
appears around the filled area.

04. The following window will appear alongside the final merge after the input
of the displacement value. In the next step it will be possible to adjust the final
merging, moving the re-scanned tile in the three directions (X, Y, Z) in order to
match the correct displacement.
Note: do not save the file until the merging is complete.

05. To automatically adjust the position of the re-scanned tile, try:
‘g’:
adjusts position in the x,y,z-axes
‘h’:
adjusts position in the x-axis
‘k’:
adjusts position in the z-axis
‘j’:
adjusts position in the y-axis
06. To manually adjust the position of the re-scanned tile, try:
‘q’:
moves tile down along z-axis by 50 microns
‘w’:
moves tile up along z-axis by 50 microns
‘e’:
moves tile down along z-axis by 10 microns
‘r’:
moves tile up along z-axis by 10 microns
‘u’:
moves tile left along the x-axis (-x) by 50 microns
‘i’:
moves tile right along x-axis (+x) by 50 microns
‘o’:
moves tile down along y-axis (-y) by 50 microns
‘p’:
moves tile up along the y-axis (+y) by 50 microns
07. If the two tiles have been correctly merged, it will be impossible to tell where
the join is i.e. there will be no artifacts. Once you are satisfied with the result,
press ‘a’ to save the outcome as a 32 bit TIF. Then press ‘s’ to save it as a
RIS file. It is suggested that the user save the file in both formats. If the merge
is still unsuccesful, press ‘x’ and restart the merging process with a different
displacement value.
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<<<
Raphael, The Holy Family with the Lamb, C16th, ink on paper, 27.5 x 22.7 cm (detail).
3D scanned in 2015 in the Ashmolean Museum, Oxford.
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Editing original data
The Editing Application is used for improving (cleaning, correcting...) the
original relief data obtained with the Lucida 3D Scanner. It has been specifically
designed to deal with common artifacts that appear in most recordings, such as:
‘Noise’: grainy texture that appears all over the scanned data, usually when
the used laser intensity used is too high for the characteristics of the recorded
material (glossiness, darkness, etc.).
‘Spikes’: artifacts in the shape of single points that are elevated too far above
the average height of the recorded data. These are usually produced by shiny
materials.
‘Gaps’: local absence of data, produced by a range of causes, which results in
black areas of a few pixels size. These areas must be filled by the Editing App
in order to guarantee the continuity of the data.
‘Rain’: artifacts in the shape of floating points that appear around the edges of
the scanned data, produced by reflections of the laser.
A subjective process
Modifying original scanned data involves taking a series of decisions that will
affect the final result. The user has many options when editing the data. Which
option is taken depends on the desired output for the scan... (whether it is for
visualization, prototyping, combination with other types of 3D data...).
For heritage documentation it is essential to keep the original files as a record of
the information captured by the scanner. There are infinite ways of processing
the recorded data but there is only one original version, which contains
information that could become relevant at a later stage.

The Editing Application can load Lucida tiles as RIS format and save as RIS, 32
bit TIF (depthmap) or 8 bit TIF (shaded) file formats.
The Editing App can only operate on one tile at a time. For editing a series of
tiles it is necessary to carry out the same process for each of them. Various
tiles of the same object will probably require similar settings. Therefore, after
determining the optimum settings for the first tile, the same settings can be
applied to the rest of them.
Tools & Commands
The Editing app allows the user to modify the original data using two types
of elements: tools and commands. Whereas the tools can be applied to a
specific area, the commands are filters that are applied to the whole tile. In
both cases it is possible to specify the extent or the intensity of the correction.
The range and recommended values will be described specifically for each tool
and command. The order in which the tools and commands are applied will
influence the final result.
The quality of the Editing proccess depends on the operator’s eye and
experience. The specific steps for cleaning or correcting a tile depend on
each case and should be determined by trial and error. The general aim of the
Editing process is to eliminate or reduce the different artifacts produced during
the scanning session, and which are not part of the real data. The process is
entirely subjective... because deciding when the editing process is complete
depends almost entirely on the operator’s judgement.
The optimum result is achieved when the data is continuous (without gaps),
coherent (without spikes or floating points) and corresponds to the real surface
(with less noise). However, it is important to make sure that this ‘cleaning’ does
not modify the original data too much. In other words, for each dataset it is
important to find a middle ground.
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The user interface
1 Full view window: displays the full tile. With the cursor it is possible to navigate or select the area that you want to zoom into.
2 Tools menu: contains the list of editing commands.
3 Commands window: contains the list of editing commands and allows the
user to insert intensity values for the different filters. Press ‘Esc’ at any time to
make the Commands window visible again.

4 Zoom view window: displays a zoomed-in view of the selected area. This
window shows the area in detail, allowing the user to test and check the effect
of the different filters and tools applied in the editing process.
Required screen resolution: 1920 x 1080 px.

1

4

2

3
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Tools & Commands
List of Commands
The commands can be selected by typing their correspondent key:
‘w’: load the 3D data from a RIS file.
‘a’: save the 3D data as 32 bit TIF file.
‘q’: save the 3D data as a RIS file.
‘s’: save the shaded render as 2D TIF file
‘x’: exit (without saving)
Note: after editing a tile it is recommended that the user always saves
a file in the three formats: RIS, 32 bit TIF (depth map) and 8b bit TIF
(shaded). Where possible, the user should also select a local folder
and choose a short file name.

‘g’: ‘Fill Gaps’.
The possible values here range from 1 mm to 10 mm in diameter. The value
should be chosen according to the size of the holes or ‘gaps’ to be filled. For
small holes choose a minimum value, but always base your decision on the
largest hole in the tile to fill.
‘n’: ‘Denoise Bilateral Gaussian’.
This command reduces the noise from the surface by smoothing it slightly. This
is mainly used for flat and less textured surfaces (like paintings on canvas or
wooden panel).
‘h’: ‘Denoise, median. 3x3 kermel’.
This is a more general command to reduce speckle noise. It should only be
used for higher relief surfaces as its smoothing effect is much stronger than that
of the ‘Denoise Bilateral Gaussian’.
‘m’: ‘Spikes, median with adjustable kernel and threshold’.
This is used to eliminate spikes and it also creates a smooting effect.
‘l’: ‘Rain Filter Test’.
This command removes floating particles that occur due to excess of ambient
light, particularily found around the edges of a painting.
‘k’: save the current state.

‘f’: ‘Gaussian Smoothing’.
This command is used to smooth extremely rough surfaces. Values range from:
‘sigma’: 0.5, ‘kernel’: 3x3 to ‘sigma’:1.5, ‘kernel’:7x7. The lowest smoothing
value is 0.5 and 1.5 is the highest.

‘u’: revert to ‘saved state’ or undo the last filter.
Right click on a selected area in the Full view window to see the previous state.
In order to compare the previous and current state, alternate between the left
and right click on the mouse.
‘z’: set light source elevation angle.

Lucida 3D Scanner
Editing

Processing applications
20

Commands ‘1, 2, 3, 4’ change the view in the Full view window. Commands ‘6,
7, 8’ change the view in the Zoom view window.

Lucida 3D Scanner

Editing

‘3’: display zoom, right cabinet view.

‘1’: display zoom, left cabinet view.

‘4’: display zoom, bottom side view.

‘2’: display zoom, bird’s eye view.

‘6’: display stitching, left cabinet view.
‘7’: display stitching, bird’s-eye view.
‘8’: display stitching, right cabinet view.

Processing applications
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List of Tools
Tools are used to manually modify specific local selections in the tile. Select
the area to be edited in the Full view window and edit directly on the Zoom
view Window. Tools are secondary to Commands and should be used only if
the Command did not work to fulll effect. Input the necessary values into the
window that apears when you select the tool.
Measure: shows the coordinates of each point.
Bump: creates curvature to specific areas.
Smooth: smooths out local areas that show too much noise.
Clone mean; Clone measure; Clone median: these tools are used to replicate
texture, taking source data from nearby areas. .
Spikes: eliminates the spikes.
Rain: removes floating particles and is particularly used on the edges
Erase: it can be used to erase unnecessary data - for example data lying outside
the area of interest (outside of the painting).
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Standard session
Below is the recommended order of commands when implementing an editing
session:
01. Load the file in the Editing Application (‘w’).
02. Look for holes (‘gaps’) in the tile. Use ‘1/2/3/4’ to change views.
03. Use the ‘Fill Gaps’ (‘g’) command to fill the holes on the surface.
04. Use the ‘Rain Filter’ (‘l’) to remove the floating particles.
05. Check for more holes or gaps and if applicable fill them
again (sometimes holes that were not visible before appear as a result of
removing floating particles).
06. Use the ‘Spikes Median’ (‘m’) to remove any spikes if necessary.
07. Use the applicable ‘Denoise, median. 3x3 kermel’ (‘h’).
08. Use the ‘Gaussian Smoothing’ (‘f’) if necessary.
09. Save the file in all three formats (‘a’, ‘q’, ‘s’).
10. Exit the application (‘x’).
It is recommended that the user checks the result after applying each command.
The values will have to be determined specifically for each editing session, as
the optimum result depends on the type of data scanned.
Additionally, Tools can be used to refine certain areas where the commands did
not remove or smooth out the imperfections. It is best to apply the selected tool
directly following its corresponding command (ie. 'Rain' tool after 'Rain Filter',
'Spikes' tool after 'Spikes Median', etc.).
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Example
01. Open the Editing Application.

03. Press ‘g’ for “Fill Gaps”. Possible values range from 1-10 mm in diameter. If in
doubt choose a mid-range value (e.g. 5).
04. Remove the floating particles surrounding the scan using the ‘Rain Filter
Test’ (‘l’) command. Then enter a search radius value. This value represents the
radius from the surface above which particles will be removed. Possible values
range from 0.1 to 0.8.

02. Press ‘w’ to load the 3D data from a RIS file.

Note: pay particular attention to the edges by using the side view. Select an
area in the render view window and press ‘4’ to display zoom, bottom side view
in order to make the floating particles visible.
05. You will then be prompted to enter the percentage threshhold value as an
integer. For scans with more floating particles use a higher threshold value. The
value to be used is subjective, but 75 is typical. For this example the search
radius value was 0.5 mm with a 60% threshold.
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Result after ‘Rain Filter’:

Lucida 3D Scanner

Editing

Processing applications
27

07. The next steps varies for different scans depending on their texture and the
amount of relief present in the data:
- for high-relief surfaces press: ‘h’ for ‘Denoise, median. 3x3 kermel’
- for flat/low-relief surfaces press: ‘n’ for ‘Denoise Bilateral Gaussian’
This example requires the ‘h’ command because the texture is rough:

06. Revise the data for any other holes that were not visible earlier. It is usual to
find more holes appearing as some of them were covered by floating particles
now removed by the rain filter. If applicable, press ‘g’ for ‘Fill Gaps’ again.
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08.The final step involves saving the file in three different formats:
8.1. Press ‘q’ to save the 3D data as a RIS file
8.2. Press ‘a’ to save the 3D data as 32 bit TIF file
8.3. Press ‘s’ to save the shaded render as 8 bit TIF file
09. Press ‘x’ to close the Application.
10. Now apply similar editing steps to all the tiles recorded from the same
object. After all tiles have been edited, they are ready for the next processing
step: Aligning (with PTGui).
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<<<
Verdure tapestry, anonymous, C18th, wool and silk, 385 x 436 cm (detail).
3D scanned in 2015 in the Real Fábrica de Tapices, Madrid.
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PTGui

Loading images

The process of aligning (or stitching) various tiles recorded with the Lucida 3D
Scanner is performed using the panoramic composite software PTGui. This
tutorial describes the step-by-step process using PTGui Pro 9.2.0 on Windows 7.

01. Open PTGui.
02. A series of default settings must be changed before starting:
2.1. On the Menu bar click on ‘Options’ (under a tool icon).
2.2. Go to ‘Advanced’ tab and uncheck ‘Load 16bit as 8 bit’.
2.3. In the same tab check ‘Allow stitching even if estimated TIF/PSD
size is over 4Gb’.
2.4. Check ‘Disable SSE/AltiVec acceleration’.
03. On the top right corner of the software interface clik on the ‘Advanced’ tab
in order to access the advanced options.
04. Select the image files: ‘Project Assistant’ > ‘1. Load images...’

One of the great advantages of Lucida is the possibility of working with 3D
information as TIF files, both as depthmap and shaded. The alignment process
roughly consists of two steps: first, create a panorama using the shaded renders
(8 bit TIF files); second, substitute each tile with its correspondent depthmap
(32 bit TIF files).
Do not use original files for aligning. Instead, use the edited and merged tiles
you have created in the previous processing steps.
At the end of the process two panoramas will be generated: a shaded panorama,
which can be used as an image, and a depthmap panorama, which can be used
as 3D information for various outputs.

05. A window will pop up saying that no EXIF data was found. Do not worry about
this message: unlike most DSLRs, the Lucida scanner does not attach EXIF
data to its files. Close the window. This issue will be addressed in the next steps.
06. When the images have loaded, click on the ‘Lens Settings’ tab
6.1. ‘Lens type’ should remain ‘Rectilinear’. Set ‘Focal Length’ to 17,300
6.2. ‘Lens correction parameters’ should remain as ‘0’. This will avoid
any warping to the images.
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Control points
07. On the ‘Panorama Settings’ tab ‘Projection’ should be set to ‘Rectilinear’ in
order to keep the lines straight.

09. Assign control points. PTGui calculates the translations and rotations
required for an image to fit with its neighbour by using a minimum of four
'correspondence points'. This can be done automatically by the software but to
ensure accuracy it is better to do it manually.
Note: the accuracy of the control points should be sub-pixel. To identify whether
this is the case, use the Optimize button (step 15).

08. Click ‘Align images’.

09.01. Click on the ‘Control Points’ tab.
09.02. Select a pair of overlapping images, for instance:
‘Image 0’ and ‘Image 1’.

It is recommended to preview the stitched panorama by clicking on the
‘Panorama editor’ icon on the Menu bar or using the shortcut ‘Control + E’.
09.03. The pair of images as currently displayed in the viewer are too small
to achieve a good pixel correlation. Adjust the Zoom to around 50%.
Locate any clear visible features, as shown in the image below.
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09.04. Once features have been located, increase the Zoom level until the
chosen feature can be clearly identified. In the example below, the
Zoom is set at 200%.
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09.07. The first control point will now show up on the lower part of the
interface. The distance value will be displayed once the project
is optimized. From this value it will be possible to determine whether the
assignment of control points was accurate enough.

09.05. Once the corresponding features have been located, go into the left
hand viewport and left-click on the feature .
Note: it’s fine if you forget where you’ve clicked exactly because PTGui will
anchor these small windows for you.
09.06. Within the right hand viewport, click on the same feature as in the
left hand viewport. Guide your eye using the small anchored window.

09.08. Repeat this process for each of the four pairs of images.
Note: once you have set 2 corresponding points manually, PTGui will be able to
automatically estimate the rest for you.
10. Click on the ‘Optimizer’ tab and click on ‘Optimize’ in the bottom left corner
or press F5.
10.01. The average error should be lower than 1 pixel. If the average
error ir higher or equal to 1.00, repeat the placement of the control
points as many times as necessary. To manage the control points click
‘Tools’ > ‘Control Points’.
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13. Click on ‘Create Panorama’ tab.
13.01. Click on ‘Set optimum size’ and then click on ‘Maximum size’ to
make sure there is no loss of any details.
13.02. Set the ‘File format’ to ‘Photoshop large file .psb’.
13.03. Click on ‘Layers’ > ‘Blended Panorama only’.
13.04. Adjust the ‘Feather’ to be close to the sharp side.

12. At this point it is recommended that the user previews the resulting panorama
by clicking on the ‘Panorama editor’ icon on the ‘Menu’ bar or using Control + E.
The tiles below have been succesfully stitched together:

13.05 Click on ‘Create Panorama’.
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Replacing images
14. Open ‘PTGui’ > ‘Open the stitched project’.
15. Go to the ‘Source Images tab’ and right-click ‘Load Mask’ on each image.
Load the corresponding saved mask from Photoshop.
16. Go to ‘Source Images’ and right-click ‘Replace’ on each image to
replace them with the corresponding depth map file.

17.02. Click ‘Tone map settings’ > disable ‘Dynamic radius adjustment’
and set ‘Radius’ to 0.

18. Within automatic exposure and colour adjustment click on ‘Settings’.

17. Once all the tiles have been replaced with their corresponding depth map
files, click the ‘Exposure/HDR’ tab.
17.01. Check ‘Exposure correction’, ‘Enable HDR stitching’ and select
‘True HDR’.
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18.01. Disable ‘Optimize Vignetting’, enable ‘Full optimize exposure’ and
click ‘OK’.

19. Within ‘Automatic exposure and colour adjustment ‘ click on ‘Optimise now’.
The Z values of each tile should have been compensated.
20. At this point check whether the exposure has been compensated correctly.
Press ‘Control + E’. All transformations are done linearly.
21. Some black straight lines might be visible on the edge of the tiles within the
Panorama editor. To remove them, click the ‘Mask’ tab and outline the
overlapped parts of the tiles with the round red tool.
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21.01. Press ‘Control + E’. All transformations are done linearly.

22. Go to the ‘Create Panorama’ tab.
22.01. Click ‘Set optimum size’ and then click ‘Maximum size (no loss of
detail)’. ‘HDR file format’ should be set to ‘Photoshop large (.psb)’.
22.02. ‘Output’ should be set to ‘– HDR – Individual HDR layers’ (disable
all the other options).
22.03. Put ‘Feather’ close to the sharp end of the scale.
23. Click ‘Create panorama’.
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E. L. Kirchner, oil on paper, 72 x 92.3 cm (detail).
3D scanned in 2014 in the Courtauld Institute, London.

Lucida 3D Scanner
Blending

Processing applications
44

Lucida 3D Scanner

Blending

Processing applications
45

Preparing tiles
In order for the files to be processed by the Lucida Blending App, the tiles must
have been prepared in Adobe Photoshop (CC version or higher). This example
comprises six tiles. It serves to illustrate the required steps but should be used
only as a guideline as each project will differ. Below the 8 bit TIF shaded and the
32 bit TIF depthmap versions:

01. Open the PSD file that contains the 32 bit depthmap panorama in which each
tile is in position as an independent layer. This file must have been previously
generated with PTGui.
02. Check that the file is correct by selecting any layer and going to: Image >
Adjustments > Levels and change the values to ensure that the relief looks as
expected. Do not save changes.

03. Delete all layer masks that may have been
created in PTGui. Right-click on each Layer Mask
> Delete Layer Mask.
04. Check that 32 Bits/Channel is on:
Image > Mode > 32 Bits
05. Adjust to correct resolution:
Image > Image Size > Resample: Off (unchecked)
> Resolution: 254 pixels/inch

Gough Map of Great Britain, Ashmolean Museum, Oxford.
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Note: The ‘eye’ button on the left of each layer will show/hide the layer, making
its location identification on the canvas.
11. Reduce the opacity of the layers (e.g. 50%) to illustrate the overlap between
tiles. The standard overlap between tiles should be around 50 mm.
Note: click on the ruler at the edge of the screen to change the dimensions to mm.

Note: when ´Resample´ is off, changing the resolution will change the width/
height dimensions accordingly and not the overall ´Image Size´. As a result, the
file will be in ‘real dimensions’.
06. Image > Mode > Grayscale > Merge layers?... > Don’t Merge
07. Edit > Color Settings > Gray > Linear
08. Modify the canvas size: Image > Canvas Size... > New Size: Width: 17000
px / Height: 9602 px (or 1700 x 960.2 mm)
Note: if the file that has been stitched is larger than the new size listed above,
the file must be split into sections. With the current Blending app this is the
maximum file size that can be blended.
09. Create a 100% black /or white) background layer: Layer > New > Name:
Background / Colour: Black > OK. With the new Background layer selected, use
the Rectangular Marque Tool (see below) and outline the whole canvas. Right
click > Fill: Black. Drag Background Layer to the bottom of the Layer Panel.
10. Change the name of each layer to its corresponding tile name e.g. 1A, 1B,
1C, 2A, 2B, 2B, 2C, etc. The horizontal dimension (rows) is marked with letters
and the vertical (columns) with numbers.
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12. Drag guides from their corresponding horizontal and vertical rulers and place
them onto the overlapped area to outline a space that is ≥ 10 mm and ≤ 25 mm. It
is best to zoom in at this point to ensure accuracy and check that the overlapped
area does not include any holes as they may be problematic later on.
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13. After marking all overlapped areas within the correct range (in between 10 and
25 mm), use the Rectangular Marquee Tool to select an area that encompasses
the excess overlap of each layer (overlap area outside the marked section). Then
delete the excess area from the selection adjacent to the tile. Repeat this operation
for each layer.
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14. In order for the Blending app to work correctly, the borders of the overlapped
sections must be evened out. With the guides still in place, zoom in at the edge
of an overlapped area and use the Lasso or Polygonal Lasso Tool to remove
any uneven edges. Do this for all vertical and horizontal overlapped tiles.

Before / After

Note: after removing the excess of overlap from every layer the resulting file
must look like this (see image below). It is recommended that the user saves
changes at this point as an intermediate step, so it is possible to return to this
stage in the process if necessary.
For instance, save the file as: [name of work]_progress1.psb

Before / After
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15. Change the opacity of the layers back to 100% and remove the guides:
View > Clear Guides.

Save Channels In: Interleaved order
Byte Order: IBM PC

16. Save one RAW file for each independent tile. To do this, turn off all layers
except the tile to be saved and the background layer.

18. Finally, save the Photoshop as eg. [name of work]_progress2.psb
All tiles are now ready to import into the Blending application.
Note: in order to avoid height distortion when working with Lucida
reliefs in Photoshop, load the “Lucida_depthMaps_linearity.csf” colour profile.
This colour profile is provided with the Lucida software distribution. To load the
colour profile:
- Select Edit -> Colour Adjustment.
- A dialogue window will appear.
- Select ‘Load’.
- Find the ‘Lucida_depthMaps_linearity.csf’ file.
- Click ‘Ok’.
From now on the linear colour profile will be selected by default.

17. File > Save As… > save as the corresponding tile name (eg. 1A) and as a
RAW file. Repear this operation for each tile.

Support: factum@factum-arte.com / +34 915 500 978
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Blending tiles
The Lucida Blending application blends the tiles by aligning them along the
Z-axis. Usually, the tiles are first blended horizontally in terms of each row. The
resulting rows are then blended vertically to create a complete 3D file. The order
of blending may vary depending on the nature of the project.
Horizontal blending

Vertical blending

04. Press any key except ‘s’ and ‘x’ and load 1C, the last horizontal tile to
complete row 1.
05. When all horizontal tiles have been blended for this row press ‘s’ and
save as ‘1.raw’. The saved file should be in RAW format, although this will
not be an option on the computer. This must be manually inputted by adding
´File_Name.raw´.
06. Repeat this process for row 2 (tiles 2A, 2B and 2C) and save the row as ‘2.raw’.

Both the Horizontal Blending app and Vertical Blending app can load and save
only RIS files with a canvas size of 17000 x 9602 px. Make sure all RIS files are
loaded from, and saved to, a local hard drive.

Vertical Blending application
07. Blend the two rows using the Vertical Blending Application:
23000Blend2Rows.exe
08. Open the Application and load ‘1.raw’ into the App. When asked, load ‘2.raw’.

Horizontal Blending application
01. Open the Horizontal Blending application: BlendingApp64bits.exe
02. The message ‘Please load the first file’ will appear. Navigate to the correct
folder and load tile1A.
03. When prompted load tile 1B.
Note: the overlap amount must fall comfortably within the 10-25 mm range (in
this example: 13.6 mm). If the value is out of range it means there is a problem
with the preparation of the files in Photoshop. If this is the case, go back to the
Photoshop file and review the overlap.

Note: again, the overlap must be between 10 and 25 mm. In this case 14.6 mm
means the files have been successfully blended.
09. Press ‘s’and be sure to add ‘.raw’ to the end of the file name.
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10. Open the final RAW file in Photoshop. Photoshop will not recognize the file
as is. In order to open the file, alter the following parameters in the Photoshop
Raw Options tab:
Width: 17000 pixels
Height: 9602 pixels
Depth: 32 bits
Byte Order: IBM PC
> OK
Specified image is smaller
than file, open anyway?
> OK

12. Highlight the adjustment shadow input level number (box on far left) and zoom
in close to the image. Use the mouse wheel to adjust the numerical value in the
adjustment shadow input level box. Simultaneously adjust the levels and navigate
across the image (especially the borders) in order to view any discrepancies.

11. Use the levels to check that there are no mistakes in blending. Go to
Image > Adjustments > Levels. Move the black arrow on the left (under Input
Levels) closer to the middle arrow and notice the change in levels of the image
(see p. 12). By doing this you will be able to see the relief of the file. Important:
do not save any changes.
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Note: the previous image shows that there was a problem with the blending
procedure, indicated by the artifact (rigid line). When checking for discrepancies
be sure to notice anything that seems out of character with the texture of the
scanned surface, like features too uniform or straight, particularily along the
edges. If problems are found, return to the preparation of the files in Photoshop
and check that the overlapped borders have been evened out and that all the
outlined parameters are met.
Saving as 32 bit TIF file
13. Once happy with the blending result, you have to save the file as a 32 bit
TIF. Change the resolution back to 254 ppi before proceeding: Image > Image
Size > Resample: Off (unchecked) > Resolution: 254 pixels/inch. Make sure the
Color profile is set to Gray - Linear.
14. Save the file as: ´[name of work]_3D_254ppi_32bit ´. The result of the
blended file will look like this:
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Saving as 16 bit TIF file
15. Go to Image > Mode > Change to 16 bit.
In the HDR Toning Window change the following parameters:
Preset: Custom
Method: Exposure and Gamma
> OK

In order to rematerialize the 3D data (CNC routing, 3D printing, etc.) it is
sometimes necessary to insert a tonal reference in the file. The detphmap
information assigns a certain height to each gray value, according to the
following scale: White = 0 mm; Black = 500 mm. All intermediate grey values
will take this range as a reference. It is therefore necessary to include at least
one black pixel and one white pixel to the file, in order to guarantee the real
dimension of the data.
16. Zoom in until the pixels are apparent. Using the selection tool, select a few
pixels on the background and Fill > Black.
17. Select a few pixels and Fill>White, always outside data.

Note: the 32 bit TIF depthmap file will contain all the information of the scanned
data in the various gray levels. Nevertheless, most output methods will require
the file to be converted to 16 bit TIF mode.
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Import into ArtCAM
18. Save as a TIF file. When saving, name the image something along the lines of:
´[name of work]_3D_254ppi_16bit_pixels´. Use these parameters when saving:
Image Compression: None
Pixel Order: Interleaved (RGBRGB)
Byte Order: IBM PC
> OK

This section explains how to import Lucida reliefs into ArtCAM, an Autodesk
software that can be used to edit 3D files in preparation for CNC milling. This
tutorial has been written for Artcam 2012 Pro and Photoshop CS6, but similar
tools will be available in other versions.
01. Open the Artcam software
02. Select File > New > From Image File
03. A dialogue window with the dimensions of the relief will appear.
Set the ‘Height in Z’ field to 500 mm.
Note: ArtCAM will measure the different depths of the grey scale image using
the 500 mm scale: pure black will mark the lowermost and pure white the
uppermost points in the scale.

04. Press ‘OK’ to finish importing the file.
19. Now the file is ready to be used in other 3D software that accepts 3D
information as 16 bit TIF files, for different types of output.
Support: factum@factum-arte.com / +34 915 500 978

Lucida 3D Scanner

Processing applications
63

Contact us
Support
factum@factum-arte.com
If you ever need help with your Lucida, email the address above. To help us
understand the problem it is very helpful to include pictures or a video as
attachments with your email.
You can also telephone us: +34 915 500 978
Feedback
factum@factum-arte.com
For general questions or for your comments and ideas send an email to the
address above.
For more information
www.factum-arte.com
www.factumfoundation.org

Resources
Lucida user’s manuals can be downloaded from Factum Arte’s website:

18P0001

Assembly Instructions
factum-arte.com/lib/kcfinder/upload/files/Lucida/manuals/2015_Lucida_A5_Assembly_Final.pdf
https://vimeo.com/8261186 (password: factum53)
Operator’s manual
factum-arte.com/lib/kcfinder/upload/files/Lucida/manuals/2015_Lucida_A5_Operator_Final.pdf
Processing applications
factum-arte.com/lib/kcfinder/upload/files/Lucida/manuals/2017_Lucida_A5_processing_Final.pdf

LucidaLab Madrid

Factum Arte & Factum Foundation
c/ Albarracín, 28
28037 Madrid
factum@factum-arte.com
carlos@factum-arte.com
tel. +34 915 500 978

LucidaLab London

Factum Foundation
44 Lexington Street
London W1F 0LP
info@factumfoundation.org
eva.rosenthal@factumfoundation.org
tel. +44 20 7439 8287

LucidaLab Milano

Factum Foundation
Via Piranesi, 10
20137 Milano
info@factumfoundation.org
guendalina@factumfoundation.org
tel. +39 02 36736436
factumfoundation.org
factum-arte.com

